Port Channel Configuration Cisco MDS SAN Switch

In this blog, we will discuss what is port-channel in the Cisco MDS switch. Along with that, we will also talk about the F port Channel, what are the types of port-channel, Modes of port-channel.

Finally, we will see the commands for creating an F port channel between a Cisco MDS core switch and an NPV switch.

How To Configure F Port Channel Cisco MDS Switch
How To Configure F Port Channel Cisco MDS Switch

What Is Port Channel In Cisco SAN Switch

  Port Channel is a logical aggregation of multiple FC ports that increases total bandwidth, provides load balancing, and link redundancy. A Port-channel can have ports from two different modules in the same SAN switch.

You cannot create a port-channel from two different switches. This is more clear in the below diagram.

Port Selection In Cisco MDS Port Channel
Port Selection In Cisco MDS Port Channel

    The above diagram has two switch switch1 and switch2. There are three port-channels between the switches PortChannelA, PortChannelB, and PortChannelC.

PortChannelA contains an aggregation of ports from the same module of both switches. Meantime, PortChannelB has ports from two different modules.  

Now in the case of PortChannelC, there are three ports from each switch. In switch1 two ports are from the same module but the third port is from a different module. In switch2 all three ports are from the same module.  

The conclusion here is that you can select various port combinations in the same switch but you cannot select ports from different switches.

What are the Types Of Port Channel

There are two types of port-channel E port-channel and F port channel. E Port Channel is a logical combination of Multiple E ports. E Ports connect two SAN Switches for ISL connectivity.

If we enable trunking then the port-channel then it becomes a TE port channel and the ISL link becomes EISL.

F Port Channel is a logical Combination of Multiple F ports that connects from one Switch (F) to NPV switch (NP) or FI interconnect.

Modes Of Port Channel In Cisco MDS Switch

  There are two types of Port Channel Mode one is ON and the other is ACTIVE. Both modes have a different purpose. Below are some basic differences between them.  

ONACTIVE
DefaultYou must explicitly configure this mode.
Need To Disable port while adding or modifying members to port-channel.Port-Channel automatically recovers while adding or modifying it.
Not RecommendedRecommended
Only Supports E port-channelSupports both F and E port-channel

How To Configure F Port Channel In Cisco MDS Switch

This section will discuss how to create an F Port Channel between the Cisco MDS switch and NPV switch. Before we start we have to check a few things which are very important for port-channel configuration.

The first thing we need to make sure that Physical connection is present between switches.

Configuration of individual ports and port channel must be the same. Make sure configuration like speed, mode, rate mode, port VSAN, trunking mode and allowed VSAN for individual port and port-channel are the same.

Steps and Commands To Create F Port Channel

Step 1. Enable F port trunking and channel protocol

Switch(config)# feature fport-channel-trunk

Step 2. Enable NPIV on the MDS core switch:

Switch(config)# feature npiv

Step 3 Create PortChannel and Add FC Ports

  This command creates a port-channel with name 1.  

Switch(config)# interface port-channel 1

These commands ensure that the port-channel type is F port-channel

Switch(config-if)# switchport mode F

Below commands sets channel mode active. F port channel only supports ACTIVE port-channel mode hence it is important to set the channel mode as ACTIVE.  

Switch(config-if)# channel mode active

Below Command disable the trunking in Port Channel  

Switch(config-if)# switchport trunk mode off

The below command sets the rate mode of port-channel to shared.

Switch(config-if)# switchport rate-mode shared
Switch(config-if)# exit


  Till now we have completed creating an F port-channel in Core Switch whose number is 1. Now in the below steps, we will add ports to Port Channel 1.

Make a note that the configuration for Port Channel 1 and the interfaces must be the same.

Step 4. Configure the PortChannel member interfaces

  Below two commands select FC ports fc2/1 , fc2/2 and fc2/3 as port-channel members and then disable them  

Switch(config)# interface fc2/1-3
Switch(config-if)# shut

Below four commands will set the port mode as F, disables the trunking, set the speed as 4000 and the rate mode as shared.  

switch(config-if)# switchport mode F
switch(config-if)# switchport trunk mode off

switch(config-if)# switchport speed 4000
switch(config-if)# switchport rate-mode shared


  Below commands is for adding the interfaces to the port-channel. In this case ports fc2/1, fc2/2 and fc2/3 are added to Port Channel 1. The second command will disable all ports.  

switch(config-if)# channel-group 1
switch(config-if)# no shut

So far we have completed the port-channel configuration in Core switch. Now we have to repeat the same steps to configure F Port-channel an NPV switch.

Step 5. Create the PortChannel In NPV switch

eswitch(config)# interface port-channel 1
eswitch(config-if)# switchport mode NP
eswitch(config-if)# switchport rate-mode shared

Now we have to configure the individual ports and add them To Port Channel 1 in NPV switch.  

Step 6. Configure the PortChannel interfaces In NPV switch

eswitch(config)# interface fc2/1-3
eswitch(config-if)# shut

The above command will shut down all the ports that fc2/1, fc2/2, and fc2/3.

eswitch(config-if)# switchport mode NP
eswitch(config-if)# switchport speed 4000
eswitch(config-if)# switchport rate-mode shared
eswitch(config-if)# switchport trunk mode off
eswitch(config-if)# channel-group 1

Finally, you can enable all ports using the below command.

eswitch(config-if)# no shut  

The final step is to disable and enable all interfaces from both Core switch and  NPV switch. 

Step 7. Set admin State of PortChannel Ports of NPIV and NPV switch to ON

Disable and enables interfaces in Core switch.  

Switch(config)# interface fc1/1-3
Switch(config-if)# shut
Switch(config-if)# no shut

Disable and enables interfaces in NPV Switch.

eswitch(config)# interface fc2/1-3
eswitch(config-if)# shut

Last, enable all the ports.

eswitch(config-if)# no shut

This completes the F port-channel configuration between the Cisco MDS and an NPV switch. I hope you have like this. Watch below YouTube for more details. Feel free comment on this topic and Subscribe For more such videos

Leave a Reply

Your email address will not be published. Required fields are marked *